iSMARTtrain V3.0.6 Beta 16 Release

Announcements and discussion of the beta releases of iSMARTtrain
Post Reply
Stuart
Site Admin
Posts: 441
Joined: Sun Jul 13, 2008 12:15 pm

iSMARTtrain V3.0.6 Beta 16 Release

Post by Stuart » Mon Jan 04, 2010 10:30 pm

Beta 16 is out today. This release is mainly to fix a problem where Polar sessions from 2010 show up with a date of 2016 - this was because I didn't realise that the year was encoded as a BCD byte, rather than just a straight hex byte.

SonicLink download also returns in this release.

Download from the usual place - http://www.ismarttrain.com/Beta/

As usual, any problems, etc., email me or post here.

Rusty Smith
Posts: 17
Joined: Mon Jul 14, 2008 2:46 pm

Re: iSMARTtrain V3.0.6 Beta 16 Release

Post by Rusty Smith » Tue Jan 05, 2010 5:11 pm

Hi Stuart:
I just downloaded the Beta 16 version and tried it out with sonic link - no matter what I try in settings, etc, it returns
Sonic Link failed to download, please try again.


Also, the first time I launched the sonic link download, I got a window that said

MBS Plugins - this application uses unregistered plugins. Please visit our website to register these plugins....
(quicktime sequence grabber)


This window does not show up the next time I try to download, but it continues to pop up each time I exit a download.

When I roll back to the latest public release of iSmartTrain, downloads via sonic link are rock solid, first time.
Rusty Smith
MacBook Pro (Unibody)
OS X 10.6.6
iSmartTrain v3.0.8 Beta 3
Polar Serial Adapter with Keyspan USA-19HS
Polar S625x
Polar cs200
Garmin Edge 500
Garmin Edge 800
Garmin Forerunner 310xt

Stuart
Site Admin
Posts: 441
Joined: Sun Jul 13, 2008 12:15 pm

Re: iSMARTtrain V3.0.6 Beta 16 Release

Post by Stuart » Thu Jan 07, 2010 4:15 pm

Rusty Smith wrote:Hi Stuart:
I just downloaded the Beta 16 version and tried it out with sonic link - no matter what I try in settings, etc, it returns
Sonic Link failed to download, please try again.


Also, the first time I launched the sonic link download, I got a window that said

MBS Plugins - this application uses unregistered plugins. Please visit our website to register these plugins....
(quicktime sequence grabber)


This window does not show up the next time I try to download, but it continues to pop up each time I exit a download.

When I roll back to the latest public release of iSmartTrain, downloads via sonic link are rock solid, first time.


Hi Rusty,
Try Beta 17 - http://www.ismarttrain.com/Beta/

Thanks & Regards

Stuart

rmulder
Posts: 5
Joined: Tue Aug 19, 2008 9:13 am

Re: iSMARTtrain V3.0.6 Beta 16 Release

Post by rmulder » Sat Jan 09, 2010 9:44 pm

Hi Stuart,

I had the same problem as Rusty with Beta 16 and Sonic Link. It doesn't seem to be resolved in Beta 17. The MBS plugin message has disappeared but now the program hangs at the 'Waiting ..." stage after I click 'start' to commence data transmission (ie it doesn't switch to 'Recording' as it normally would). I've attached a grab of the window.

Thanks,
Raoul
You do not have the required permissions to view the files attached to this post.

Stuart
Site Admin
Posts: 441
Joined: Sun Jul 13, 2008 12:15 pm

Re: iSMARTtrain V3.0.6 Beta 16 Release

Post by Stuart » Sat Jan 09, 2010 10:43 pm

rmulder wrote:Hi Stuart,

I had the same problem as Rusty with Beta 16 and Sonic Link. It doesn't seem to be resolved in Beta 17. The MBS plugin message has disappeared but now the program hangs at the 'Waiting ..." stage after I click 'start' to commence data transmission (ie it doesn't switch to 'Recording' as it normally would). I've attached a grab of the window.

Thanks,
Raoul


Hi
Yes, there looks like there's a problem with the text that's displayed. When you click on the 'Start' button, it'll go to a solid blue colour. When it changes to a flashing blue (like a normal, default, button), start the download. Obviously, this is something we need to fix before the final release, but it should get you up-and-running.

Thanks & Regards

Stuart

rmulder
Posts: 5
Joined: Tue Aug 19, 2008 9:13 am

Re: iSMARTtrain V3.0.6 Beta 16 Release

Post by rmulder » Sun Jan 10, 2010 4:27 am

Hi Stuart,

Thanks for the advice. When I click on 'Start' the button doesn't change from blue to flashing; it just goes grey. However, if I wait a few seconds and then start downloading even though there's now obvious status change (dialog box still says 'Waiting ...') the session download does get saved.

Raoul

dmsaban
Posts: 5
Joined: Fri May 15, 2009 5:53 am

Re: iSMARTtrain V3.0.6 Beta 16 Release

Post by dmsaban » Thu Jul 15, 2010 2:39 am

I am experiencing the same on this version and the most recent update. With the further issue that I get the error: "bash: /Applications/iSMARTtrain.app/Contents/MacOS/S410BSD: Permission denied" and I am unable to download any data. using a new MacBookPro MacOSX 10.6.3, old MBP worked fine. Seems like a permission error. I am not using an account with admin privs.

Stuart
Site Admin
Posts: 441
Joined: Sun Jul 13, 2008 12:15 pm

Re: iSMARTtrain V3.0.6 Beta 16 Release

Post by Stuart » Tue Jul 20, 2010 8:26 am

dmsaban wrote:I am experiencing the same on this version and the most recent update. With the further issue that I get the error: "bash: /Applications/iSMARTtrain.app/Contents/MacOS/S410BSD: Permission denied" and I am unable to download any data. using a new MacBookPro MacOSX 10.6.3, old MBP worked fine. Seems like a permission error. I am not using an account with admin privs.


Hi,
This is fixed in the release version of 3.0.7.

Regards

Stuart

dmsaban
Posts: 5
Joined: Fri May 15, 2009 5:53 am

Re: iSMARTtrain V3.0.6 Beta 16 Release

Post by dmsaban » Wed Jul 21, 2010 3:49 am

I can confirm: Version 3.0.7 fixes this.

Thanks!

Post Reply