Mac OSX Keyspan USB Adapter Gone After 3.0.9 Upgrade

Discussions about the current release of iSMARTtrain
Post Reply
randy
Posts: 5
Joined: Tue Feb 10, 2009 1:05 am

Mac OSX Keyspan USB Adapter Gone After 3.0.9 Upgrade

Post by randy » Mon May 16, 2011 12:01 am

I've been using iSMARTtrain for 3 years on my Mac with the Keyspan USB adapter.

Immediately after upgrading to 3.0.9 this afternoon, my Keyspan device disappeared from the drop-down select. In its place, I now have only 4 Garmin devices. I have never used a Garmin device of any sort with iSMARTtrain, so this seems bizarre.

Obviously, this bug prevents all data download. An attempt to download data from my Polar receives the "No Garmin Device Found" error dialog.

Even worse, the entire application becomes unresponsive, and has to be rudely killed (on a Mac, that is called Force Quit...).

My mac is running OSX 10.6.7.

- Randy

Stuart
Site Admin
Posts: 441
Joined: Sun Jul 13, 2008 12:15 pm

Re: Mac OSX Keyspan USB Adapter Gone After 3.0.9 Upgrade

Post by Stuart » Mon May 16, 2011 7:46 am

Hi Randy,
Let me have a look at this tonight. The Garmin devices have always been there undar the USB option, but your Keyspan device should have appeared as a separate device in the 'Ports' list. Basically, the software lists everything that appears as a serial port, hence the reason you'll occasionally see a Bluetooth device listed.

I'll look into this tonight and get back to you.

Regards

Stuart

Stuart
Site Admin
Posts: 441
Joined: Sun Jul 13, 2008 12:15 pm

Re: Mac OSX Keyspan USB Adapter Gone After 3.0.9 Upgrade

Post by Stuart » Mon May 16, 2011 6:06 pm

Hi Randy,
I've checked with my installation of iSMARTtrain and it appears to be showing the Keyspan devices correctly. Can you check yo make sure that you have the driver installed, please.

Thanks

Stuart

Post Reply